Critical Update: Upcoming PCI changes require store updates to be applied

Critical Update: Upcoming PCI changes require store updates to be applied

As you may be aware, the PCI Security Standards Council has updated its requirements on what is required for a site to operate in a secure PCI approved environment.
 
So what do the upcoming PCI changes being implemented in the coming months regarding TLS mean for you? 
 
Nearly all merchants will need to make some form of changes to their stores. Some large, some small. It will depend on where you are hosted, what sort of backend database you are using and how old your store is.
 
Do I need to make any changes?
 
 

Merchants using VPCart 8.1.00 and higher

If you are using the very latest version of VPCart, 8.1.xx or higher for example, and you are on a Windows 2012 server then there is nothing that you personally need to do for the PCI changes as you are already up to date.
Your host will need to make sure that their server configurations are up to date as well but other than that you are good to go.
 
NOTE : If you are using 8.1.xx or higher and are on a Windows 2008 server, you will need to enable TLS 1.2. You may refer to our write up on How To Enable TLS 1.2 On Windows Server.
 

Merchants using VPCart 8.00.xx 

If your store is running VPCart 8.00.xx then you need to update your stores code so it remains firstly compatible and secondly operational.
 
Slowly but surely all 3rd party providers of gateway and shipping services for example will be ceasing support for the XML components needed to connect your store with the gateway or shipping provider.
 
If you are using UPS for example you will have already started to see intermittent outages as they test the new settings.
 
You have 4 options :
  1. Upgrade using full version to completely refresh your store
  2. Apply the Service Pac to your VPCart 8.00.xx store – Recommended
  3. Apply the module update for VPCart Version 8  – Easiest
  4. Switch to our Business Ready Plan and we will migrate and upgrade your store for you to latest and greatest version.  
You will also need to update the modules (payment gateways and shipping interfaces). If you do not have any customization done on the modules, you may download the updated modules directly from :
On the other hand, if you have customised your modules, you may update the file manually by following the steps given in this article called "Updating TLS 1.2 Security Patch".
 
Both the Upgrade and Service Pac options requires a current license.
 
NOTE : If you are using 8.0.xx or higher and are on a Windows 2008 server, you will need to enable TLS 1.2. You may refer to our write up on How To Enable TLS 1.2 On Windows Server
 

Merchants using VPCart 7.xx

If your store is running VPCart 7.xx then you need to update your stores code so it remains firstly compatible and secondly operational.
 
Slowly but surely all 3rd party providers of gateway and shipping services for example will be ceasing support for the XML components needed to connect your store with the gateway or shipping provider.
 
If you are using UPS for example you will have already started to see intermittent outages as they test the new settings.
 
You have 3 options :
2. Apply the module update for VPCart Version 7 – Easiest 
3. Switch to our Business Ready Plan and we will migrate and upgrade your store for you to latest and greatest version. 
 
You will also need to update the modules (payment gateways and shipping interfaces). If you do not have any customization done on the modules, you may download the updated modules directly from :
On the other hand, if you have customised your modules, you may update the file manually by following the steps given in this article called "Updating TLS 1.2 Security Patch".
 
The Upgrade option requires a current license and you may upgrade your license here.
 
NOTE : If you are using 7.xx or higher and are on a Windows 2008 server, you will need to enable TLS 1.2. You may refer to our write up on How To Enable TLS 1.2 On Windows Server
 

Merchants using VPCart 6.xx and earlier

Unfortunately you have drawn the short straw. To keep your store running you will need to upgrade to the latest version if you want to stay operational and PCI Compliant.
 
Slowly but surely all 3rd party providers of gateway and shipping services for example will be ceasing support for the XML components needed to connect your store with the gateway or shipping provider.
 
If you are using UPS for example you will have already started to see intermittent outages as they test the new settings.
 
As we no longer unfortunately provide support for VPCart 6.xx or earlier there are no patches or Service Pacs available.
 
You have 2 options.
2. Switch to our Business Ready Plan and we will migrate and upgrade your store for you to latest and greatest version. 
 
The upgrade option requires a current license and you can purchase the new license from here.
 
NOTE : If you are using 7.xx or higher and are on a Windows 2008 server, you will need to enable TLS 1.2. You may refer to our write up on How To Enable TLS 1.2 On Windows Server
 

So what now?

Great question. We are here ready to work with you to help make this transition as smooth and painless as possible.
 
Hosting your VPCart StoreFront :
If you are hosting with us you will already be on a compatible server as we are now wrapping up the last of our upgrades. If not, you may read How To Enable TLS 1.2 On Windows Server
 
For the engine room side of things if you are Business Ready merchant we will be applying the Service Pac if you have not made many changes to your code. If you have made a lot of changes we will be applying the Update Patch as this impacts only a few files.
 
We will notify you as we go through our list as to when to expect your site to be updated.
 
If you are hosting with us on a standard hosting plan you can either apply the updates yourself or reach out to us through the HelpDesk portal and request that we do it for you. We will review your site and let you know the best option and if there is a cost applicable.
 
Hosting with a third party hosting provider :
If you host with an outside host then you must make sure they have you on a server where TLS 1.2 is enabled.
 
Some of you are using Access as your database and many hosts are now no longer offering support for Access.
 
You can either convert to SQL or MySQL Server using the Database Conversion tool which can be downloaded from our site or you can switch to VPCart Hosting as we still support Access as well as SQL and MySQL.
 

Have questions?

Feel free to contact us through our Helpdesk Portal with any questions that you might have and our dedicated support team is available 24 hours a day Monday to Friday to answer any questions that you might have.


Times Viewed:
4330
Added By:
debbie
Date Created:
4/19/2016
Last Updated:
6/20/2016
Back Search other topics Submit a Ticket